Pages

Friday, December 29, 2017

The Wine development release 3.0 RC 4 is now available for Linux and Mac

The WineHQ Wine development release 3.0 RC 4 is now available for Linux and Mac

What's new in this release:
  • Bug fixes only, we are in code freeze.
The source is available now. Binary packages are in the process of being built, and will appear soon at their respective download locations.


Bugs fixed in 3.0-rc4 (total 12):

  13355  Richedit very slowly open big text files
  16505  BBC iPlayer Desktop: .desktop file confuses comments with command line
  26851  Zoo Tycoon 2: Marine Mania demo installer fails
  33722  Stereo IMA ADPCM encoding in WINE produces loud static instead of sound
  34255  WinPolis 3.x: "Buy CDs" editbox does not automatically select all
  37336  U-blox U-Center 8.11 crashes when importing or exporting config file
  41070  "Call of Duty 4" does not start: heap issues
  41209  The Magic School Bus Explores the Solar System: Error message asking for the game to be reinstalled
  43971  Wine 2.20 Bcrypt compilation fails under older linux systems while Wine 2.0.3 compiles fine
  44142  steamwebhelper.exe crashes on wine-stagining 2.21 because NtQueryInformationFile fails
  44161  Possible incorrect string message in "dlls/kernel32/tests/volume.c" line 263
  44218  Black displaying of all Wine stuffs with FreeBSD

The newest CodeWeavers coupon promo code is ( UNITY ) save 30% off CrossOver Mac or Linux today!

Friday, December 22, 2017

The WineHQ Wine development release 3.0 RC 3 is now available for Linux and Mac

The WineHQ Wine development release 3.0 RC 3 is now available for Linux and Mac

What's new in this release:
  • Bug fixes only, we are in code freeze.
The source is available now. Binary packages are in the process of being built, and will appear soon at their respective download locations.



Bugs fixed in 3.0-rc3 (total 24):

   9159  shell32/explorer: Add support for Progman DDE interface
  10164  Pool of Radiance 1.4 intermittently shows garbage in surfaces
  13548  Wine's setupapi does not know how to recursively delete registry keys
  14937  Astroplanner 1.6.1 crashes when closing "preferences" window (TOOLTIPS_SubclassProc must be unsubclassed during WM_NCDESTROY)
  21849  Sonic & Knuckles Collection: arrow buttons are very narrow
  28652  SlingPlayer 2 has transparent view screen while loading
  29871  drawing in photoshop cs5 is almost impossible
  33268  SlingPlayer 2.0.4 screen flickers when pointer over screen
  35562  Slingplayer 2 crashes when starting stream
  36517  SlovoEB 2.1 (.NET 4.0 app) crashes on startup (unsupported WICPixelFormat32bppGrayFloat)
  41220  Provide fallback implementation of strnlen for OS versions that don't have it in their Libc (Leopard, Snow Leopard, et al)
  42924  Regression in Warframe - Crash when Updating user information (Usually when ending a mission). Last working version Wine 1.9.17.
  43004  qedit/tests/mediadet.c intermittent crash
  43217  Wine cannot execute position-independent (PIE) host executables via CreateProcess()
  43627  regression in Age of Empires 2: ingame mostly black in recent wine version
  44163  Far Cry crashes when opening the save game menu
  44168  Wizardry 8 hangs when starting a new game or loading a saved game
  44170  MSMoney data File password no more recognized
  44173  error: use of undeclared identifier 'kCCAlgorithmAES'
  44174  implicit declaration of function 'CCCryptorCreateWithMode'
  44180  TMIDI Player: Crash on startup with a stack overflow
  44194  Serious Sam Classic (First and Second Encounter) shifts the view and makes the game unplayable
  44196  Autocad 2002 - Scrambled numbers in output
  44201  SlingPlayer 2.0 crashes on unimplemented function mf.dll.MFGetService

The newest CodeWeavers coupon promo code is ( UNITY ) save 30% off CrossOver Mac or Linux today!

Wednesday, December 20, 2017

Run Microsoft Office 2016 and Games on Linux with CodeWeavers CrossOver 17

Yup, that means the latest version of CodeWeaver‘s commercial Wine offering also supports the latest version of Microsoft’s hugely popular Office suite, including both Home and Business editions.
And that’s big news. LibreOffice and Google Docs are near-perfect replacements for most of us, but many students and business still require the use of Microsoft Office products or file formats. As great as interoperability is these days few alternatives are as fuss-free as opting to install Office on Linux using Wine.


Other Windows software and games that feature improved CrossOver 17 support:
  • Microsoft Office 2016
  • Microsoft Office 2013
  • League of Legends
  • Everquest
  • Everquest II
  • WebSite-Watcher
  • Battle.Net
CrossOver 17 also features a large update to the Wine compatibility layer, a move that brings thousands of big fixes and usability improvements to users’ desktops and the (ever growing) array of software it supports.

Buy CrossOver 17

CrossOver 17 for Linux and macOS is available to purchase right now from the CodeWeavers website.

A free trial is also available if you want to test things out before you commit.

Wait: I thought Wine was free?

Wine is free, open-source software. It’s available to install on Ubuntu (and other Linux distributions) from the repos, for absolutely nothing.

CrossOver is (in effect) a commercial version of Wine. It’s not free; you have to pay for it. But many people are happy to do this — and no, they’re not crazy!

The newest CodeWeavers coupon promo code is ( UNITY ) save 30% off CrossOver Mac or Linux today!

Full Article

Sunday, December 17, 2017

Mariner Software Christmas Sale

Black Friday is long gone but that doesn't mean Christmas sales are over. Shop now until December 31st and receive 40% off all Mariner Software products. MacGourmet Deluxe , MacJournal, Monatge, Narrator, StoryMill, Mariner Write, Paperless for Mac, Paperless for Windows, Paperless Lite for Mac, Persona for Mac, Persona for Windows, Contour for Mac, Contour for Windows.


Just use promo code ( MARINER40 ) and receive your instant 40% discount.

Saturday, December 16, 2017

Giveaways


Refurbished Forerunner® 405CX


Retail Value: $319.99

The Forerunner 405CX is the evolution of GPS-enabled training. This sleek sport watch tracks your distance, pace and heart rate, then wirelessly sends the data to your PC for later analysis. The 405CX features heart rate-based calorie computation and comes with a second wrist band option suitable for smaller wrists.

• Advanced heart rate based calories computation
• Fits most wrists comfortably with either the original strap or the included FA high-sensitivity GPS receiver with HotFitx®
• Touch bezel interface
• Watch features time of day, dual time zone, day/date & daily alarm
• Training & motivational features through Virtual Partner®, courses, workouts & goals
• GPS features mark locations, back to start & save location
• Zone training with heart rate zone training & supports 5 heart rate zones


https://uneeqco.com/giveaways/?ap_id=twickline

You can enter here

The WineHQ Wine development release 3.0 RC 2 is now available for Linux and Mac

The WineHQ Wine development release 3.0 RC 2 is now available for Linux and Mac

What's new in this release:
  • Bug fixes only, we are in code freeze.
The source is available now. Binary packages are in the process of being built, and will appear soon at their respective download locations.


Bugs fixed in 3.0-rc2 (total 17):

  22682  Multiple games need function d3dx9_36.dll.D3DXGetShaderInputSemantics (Far Cry 2/3, Avatar, Faery: Legends of Avalon, Civilization 4, Deathspank, Of Orcs and Men)
  32202  ActiveX install attempts to run wrong inf section
  39586  Fallout 4 - Steam Version - Crash on Start-up
  40046  Multiple games require CheckFormatSupport() (Banished, Magic Duels, UE4 tech demos, BioShock 2, Chronicles of Mystara, STO, Lichdom)
  40680  Rocket league needs bcrypt.dll.BCryptGenerateSymmetricKey
  40692  Rocket League needs AES encryption/ decryption implemented in bcrypt.dll
  40901  Factorio crashes with a stack overflow
  41463  Undefined symbols: _DisableThreadLibraryCalls _RaiseException
  43643  Combobox not longer has dropdown
  43915  uTorrent 2.2.1 build 25302 crashes after deleting the last torrent and exiting
  43953  Regression in Spellforce 2: message boxes about fatal dx9 errors appear on map loading
  44010  Armel support
  44130  Possible access to unintended variable in "dlls/comctl32/imagelist.c" line 299
  44147  regression in ole2 datacache
  44148  DX Library: Multiple PlaySoundMem() calls don't work when using XAudio2
  44153  ShellExecute crash when opening explorer.exe
  44171  PTHREAD_STACK_MIN breaks build on GNU hurd

Putty for Mac Telnet SSH FTP SCP on your Mac made easy!

CodeWeavers has Released CrossOver 17.0.0 for Linux and MacOS

I am delighted to announce that CodeWeavers has just released CrossOver 17.0.0 for both macOS and Linux. CrossOver 17.0.0 has many improvements to the core Windows compatibility layer and also specific enhancements for several popular applications.



Mac customers with active support entitlements will be upgraded to CrossOver 17.0 the next time they launch CrossOver.  Linux users can download the latest version from CodeWeavers.

Change Log For CrossOver Mac and Linux :

17.0.0 CrossOver - December 5, 2017
  • Application Support:
    • CrossOver now supports Microsoft Office 2016.
    • CrossOver now supports Quicken 2017.
  • Linux:
    • League of Legends now runs in CrossOver Linux.
  • Core Technology Improvements:
    • CrossOver 17 includes an updated Wine with thousands of improvements for Windows application compatibility.
    • The default compatibility mode has been changed from Windows XP to Windows 7.
  • Bug Fixes:
    • Fixed a bug which prevented Microsoft Office 2010 from registering.
    • Fixed bugs which prevented Everquest and Everquest 2 from running.
    • Many improvements to Microsoft Office 2013 applications, including better support for drawing shapes, support for gradient brushes, and more.
    • Many Windows applications will run better on high dpi screens.



Putty for Mac
Putty for Mac
$15.00

https://winereviews.onfastspring.com/putty-for-mac


Friday, December 15, 2017

The Monthly Creatable Bundle is now Available

The Monthly Creatable Bundle is now Available. Twelve wonderful Mac apps and design goodies. A $561.85 value at over 95% off!

This bundle has now expired, you can purchase Putty for Mac at FastSpring for only $15.00

https://winereviews.onfastspring.com/putty-for-mac


https://a.paddle.com/click?said=21&aaid=3668&link_id=546&chk=5a4a9498fb18511c9b249acbcb67b5af&redir=aHR0cHM6Ly9jcmVhdGFibGUuY28vYnVuZGxlL3RoZS1tb250aGx5LWNyZWF0YWJsZS1idW5kbGUtNA==

Wednesday, December 13, 2017

Uneeq Company Launches Awesome Mac Bundle 8

Uneeq Company Launches Awesome Mac Bundle 8

Minneapolis, MN – December 13, 2017 – Uneeq Company, Inc. today launched an incredible bundle of award-winning, diverse Mac software. 8 apps, with a combined retail value of $284.88 and this Awesome bundle will cost you only $24.95 that’s a savings of 91.24% off MSRP.

Uneeq-Bundle-8

Included Applications in the Awesome Mac Bundle 7 are:

Coherence Family License – $24.99
Lucid – $79.99
PhotoBulk – $9.99
CloudMounter – $29.99
Yummy FTP Lite – $9.99
Logo Pop – $39.99
Cisdem DVD Burner 3 – $49.99
MacX MeidaTrans – $39.95

The Uneeq Mac Bundle is immediately available at https://uneeqco.com/categories/bundles/

About Uneeq Company Founded in 2015 as a online marketplace of unique computer hardware, software and tech gadgets. Uneeq is focused EXCLUSIVELY on technology – a place where visitors know that all they will see are carefully selected products that are a combination of quality and uniqueness.The company’s goal is to help software developers and hardware/tech gadget manufacturers reach a broader audience and at the same time help users find the best or most uneeq software and hardware/tech gadgets on the planet. Uneeq is a pioneer in bringing unique products to the marketplace and in located in Minneapolis, MN and Denver, CO USA. The company is privately held.

# # #

Monday, December 11, 2017

The WineHQ Wine development release 3.0 RC 1 is now available for Linux and Mac

The WineHQ Wine development release 3.0 RC 1 is now available for Linux and Mac

This is the first release candidate for the upcoming Wine 3.0. It marks the beginning of the code freeze period. There have been many last minute changes, so please give this release a good testing to help us make 3.0 as good as possible.

What's new in this release:
  • Direct3D 11 enabled by default on AMD and Intel GPUs.
  • AES encryption support on macOS.
  • Implementation of the task scheduler.
  • Registry export support in the reg.exe tool.
  • Progman DDE support.
  • OLE data cache improvements.
  • More event support in MSHTML.
  • Relay debugging improvements.
  • Various bug fixes.
The source is available now. Binary packages are in the process of being built, and will appear soon at their respective download locations.


Bugs fixed in 3.0-rc1 (total 28):

  30899  SlingPlayer 1.5 UI broken
  34328  World of Tanks: Purple graphics errors
  40714  process_attach is executed too early for forwarded exports (Oblivon Script Extender cannot load under wine-staging)
  40832  MultiSpec 2.8.2016 32-Bit: Installs fine but crashes while opening any images
  40866  DigitalMicrograph: crashes when a new script is added to the menu
  40963  Upwards, lonely robot Demo crashes with Too many buffers queued
  41269  MSI uninstaller does not clean up Registry's UpgradeCode, ProductCode
  42128  Anime Studio Professional 8 hogs CPU after it's closed.
  42307  Temple+: needs knownfolder_GetRedirectionCapabilities
  42961  Multiple apps need D3D11 depth bias support (FFXIV, Unigine: Heaven, The Witcher 3)
  43000  wine can't be compiled by gcc-2.95.4 (dsound/dsound_convert.c, C99 ~ lrintf)
  43116  Metal Slug 2 (GOG.com) can't get past the character selection screen (needs native msvcr120.dll)
  43131  Multiple apps need correct shader translation for discard_z (The Witcher 3, Star Trek Online, .hack//G.U Last Recode)
  43264  The Witcher 3: Black and red face textures and missing vegetation
  43406  NieR:Automata - Bloom to bright
  43902  close() on a closed fd should set errno to EBADF
  43905  pCon Planner crashes using builtin msvcp: access violation reading location 0x60 at basic_ios_char_widen in module msvcp140.
  43932  Fallout 4 (Steam): Low detailed LOD exterior Meshes are rendered Inside interior cell (wine missing support for SV_ClipDistanceN)
  43940  Runtime error: Invalid floating point operation in Dys-Vocal2 installer
  43956  GDI+ is unable to load some truetype fonts
  44022  The pixel format was invalid as specified (Minecraft Java, Soldiers of Anarchy)
  44064  Sims 4: unimplemented function msvcr120.dll._get_purecall_handler
  44075  Unable to set subsystem version with VC++ 2013 link.exe
  44084  Simple WPF/.Net app doesn`t start
  44085  winecfg: Use more secure HTTPS URL in about
  44088  expected declaration specifiers or ‘...’ before ‘va_list’
  44091  The Witcher: Enhanced Edition crashes during gameplay
  44104  Torchlight: rendering issue when GLSL is enabled

Putty for Mac Telnet SSH FTP SCP on your Mac made easy!
 

Wednesday, December 6, 2017

Putty for Mac version 8.7.x FAQ

Here is our current FAQ for "Putty for Mac" it should help answer the most common questions and support request.

(Q) What is Putty for Mac?
(A) Putty is one of the Best Terminal Emulators available today. It Supports different types of Network Protocols such as SSH, FTP, SCP, Telnet etc. In Windows it is used as SSH Client to connect to Your Linux server or for some other purpose But what will you do if you are on Mac? You might be thinking , Is there any Software like Putty for Mac Available? The answer is Yes! With the help of some other Software's we can Use putty on Mac although Putty is used widely on Windows Platform. Official Versions of Putty are available on Unix like Platforms, and now it's widely available for Mac systems running macOS 10.9.5 or higher.

(Q) I get this error when installing ( Error : LaunchServices: Could not store lsd-identifiers file at /private/var/db/lsd/com.apple.lsdschemes.plist ) is this a Putty error / bug?
(A) No, it's a Mac OS X bug :) See : https://discussions.apple.com/thread/7270354?tstart=0

(Q) Can I install Putty on macOS 10.13 High Sierra?
(A) YES!

(Q) How do I expand the Putty window it is very small by default?



(A)  Unfortunately at this time, Putty for Mac does not support resizing an established connection.

What you can do is create another session for your application and set a custom Window size for it by changing the Columns and Rows and then save that for future usage of that application.

I know it is not optimal and hopefully we will be able to support resizing sometime in the future.


(Q) Can I install and run Putty on OSX 10.8.x 10.9.x and 10.10.x or 10.13 High Sierra?
(A) YES! please see this post about PuTTY running on OS X 10.10 and this post about PuTTY running on 10.13 High Sierra.

Putty for Mac running on OSX 10.9.5

(Q) I cannot enter the "#" character, the key combination is Alt-3 on macOS Sierra.
(A)  In Mac, Putty has additional options in Terminal Keyboard. Uncheck Option Key Acts as Meta.  Then Alt-3 should work. See the below screen-shot...

(Q) It is not possible to paste a target host address into a new connection.
(A) Use Command+V keyboard combination (the equivalent to CTRL+V) on macOS.

(Q) It's not obvious how to launch puttygen, pageant, plink etc.
(A) puttygen, pageant, plink etc are command line programs (this is the current putty limitation of mac).  So to access these programs you have to call for example:

/Applications/Putty4Mac/PuTTY.app/Contents/MacOS/puttygen

You can also place the programs in your PATH variable so that you can just call them from the command line. 

(Q)  Where are the support forums?
(A) Coming Soon!

(Q) Can I get a free trail version?
(A) Sorry but we don't have a trial version at this time, by our 9.0.0 release we plan to have a fully functional demo / trial version available.

(Q) Do you have any videos of Putty running on MacOS
(A) Yes, we posted two short videos of the Putty install and Putty running here.

(Q) What License is Putty for Mac released under?
(A) Putty for Mac is released under a commercial license. The Putty source code is distributed under the MIT license, which is similar in effect to the BSD license. The OS X kernel (darwin) is also released under the BSD license.

(Q) Do you have volume or educational discounts?
(A) Yes, we currently have volume discounts available that max out at 50% off the normal retail price, see this post for more details.

(Q) Do you have a standalone pTerm release?
(A) Yes, after a few request we did a standalone pTerm release it can be found here.

(Q) Where can I purchase Putty for Mac and how much does it cost?
(A) Putty for Mac cost only $15.00 and can be purchased here.

Friday, November 24, 2017

The WineHQ Wine development release 2.22 is now available for Linux and Mac

The WineHQ Wine development release 2.22 is now available for Linux and Mac

What's new in this release:
  • Source selection dialog for scanners.
  • Improvements in ARM64 support.
  • Float audio formats with more than 2 channels in XAudio.
  • Fixes for DLL injection support.
  • Input methods improvements.
  • Various bug fixes.
The source is available now. Binary packages are in the process of being built, and will appear soon at their respective download locations.


Bugs fixed in 2.22 (total 14):

  29986  IE6 and IE4 have greenish toolbar icons
  42099  Bedlam (indie game) renders 3D world upside down (DX11)
  42414  The Witcher 3 intro videos don't play
  42701  Multiple apps and games using MS .NET Framework 4.x need api-ms-win-core-winrt-roparameterizediid-l1-1-0.dll.RoGetParameterizedTypeInstanceIID (Mafia III, Daylight)
  43332  rsaenh: Warning and notes while building (GCC 7.1.1)
  43333  shell32: Warning and notes while building (GCC 7.1.1)
  43335  wintrust: Warning and note while building (GCC 7.1.1)
  43336  propsys: Warning and notes while building (GCC 7.1.1)
  43800  Winamp's associations setup window has broken check boxes appearance
  43844  Skyrim can not load skse when upgrade to 2.18
  43904  HeTeMuLu Creator: Can't input some kanji characters properly.
  43946  wineboot crashes with stack smashing on aarch64
  44037  Bricscad v17 crashes on startup, needs ADVAPI32.dll.PerfStartProviderEx
  44054  Wine-mono download dialog should say wine-mono, not Mono

Putty for Mac Telnet SSH FTP SCP on your Mac made easy!

Thursday, November 16, 2017

Running PuTTY for Mac on a Retina 5K Display

I have had a few people ask me recently if Putty for Mac would run on their Retina Display and after doing some test I can happily say it runs perfectly fine. Their is however one minor outstanding issue, PuTTY won't run at ultra-high resolution at this time. Now back to working on the upcoming PuTTY for Mac 9.0.0 release.  :)

Click on the image to see the full size image :


About PuTTY for Mac :

Putty is one of the Best Terminal Emulators available today. It Supports different types of Network Protocols such as SSH, FTP, SCP, Telnet etc. In Windows it is used as SSH Client to connect to Your Linux server or for some other purpose But what will you do if you are on Mac? You might be thinking , Is there any Software like Putty for Mac Available? The answer is Yes! With the help of some other Software’s we can Use putty on MacOS although Putty is used widely on Windows Platform. Official Versions of Putty are available on Unix like Platforms, and now it’s widely available for Mac systems running OSX 10.9.5 or higher.

SSH is available by default in Mac and Linux or Unix. Although you can use terminal for SSH connections still there are some benefits in using Putty such as Other clients don’t keep connections alive whereas Putty does. Also it is cool to use Putty as your SSH client if you are doing some Amazon AWS, VMware ESXi or CISCO Stuffs, transferring files, managing files on a server or whatever.

The cost of Putty 8.7.0 is only $15.00. Anyone who has purchased Putty in the past three months is entitled to a free upgrade. Putty comes with three months of upgrades and of course a 14-day money back guarantee.

Supported Protocols:
  • Telnet
  • FTP
  • SFTP
  • SSH
  • SCP
About Wine Reviews:

There is a multitude of software developed only for the Windows operating system and even when software vendors port their applications to another platform, generally it lacks features that the Windows version contains. The only solution these developers face is to have access to both systems for testing which leads to increased infrastructure demands, and wasted project resources. Our goal is to have native ports of essential Windows tools and applications made available for MacOS users.

Monday, November 13, 2017

The WineHQ Wine development release 2.21 is now available for Linux and Mac

The WineHQ Wine development release 2.21 is now available for Linux and Mac

What's new in this release:
  • Still more metafile support in GdiPlus.
  • Indirect draws support in Direct 3D.
  • Calling convention fixes on ARM.
  • Improved serial port detection on Linux.
  • Services fixes on WoW64.
  • Better DPI scaling in the Shell Explorer.
  • Various bug fixes.
The source is available now. Binary packages are in the process of being built, and will appear soon at their respective download locations.


Bugs fixed in 2.21 (total 16):

  34601  Hydro Thunder from Midway Arcade Treasures 3 crashes quickly after the start
  37669  Resetting a write watch can cause memory access violation in kernel
  38334  SpinTires crashes with unimplemented function d3dx9_36.dll.D3DXFrameFind
  42568  user32/tests/msg.ok intermittent failure in SendMessage from other thread
  42569  user32/tests/clipboard intermittent failure ("expected freed memory")
  42570  dinput/tests/mouse intermittently fails in Acquire() and GetDeviceData()
  42863  Multiple games require sample_c_lz for cube/array textures (Winexy, Witcher 3, Flame in the Flood)
  43273  The Witcher 3 freezes the system in a certain area of the game
  43316  Process Hacker 2.x needs ADVAPI32.dll.LsaLookupPrivilegeName
  43405  NieR:Automata - Most bullets are invisible
  43483  Medusa Demo crashes with unimplemented function d3dx10_43.dll.D3DX10PreprocessShaderFromMemory
  43750  USB "ttyACM0" serial port not being created
  43853  Keepass2 fails to launch
  43884  MSVC LINK.EXE version 14.11.25547.0 crashes due to unimplemented function _memicmp_l
  43939  comctl32 cannot load its assembly on arm
  43952  kernel32/tests/console.ok fails

The newest CodeWeavers coupon promo code is ( UNITY ) save 30% off CrossOver Mac or Linux today!

Sunday, November 12, 2017

​How to run Windows apps on your Chromebook

Have you ever heard someone with a new Chromebook complaining because they couldn't run their favorite Windows application on it? I have. Now, there's a solution for them (or, for you, so you can run that one Windows application you can't live without). For years, CodeWeaver's CrossOver enabled you to run many popular Windows applications on Linux and macOS. Now, CodeWeavers is bringing those same Windows apps to your Chromebook.

Better still, the beta CrossOver on Chrome OS promises to be easier to use than ever before. Previously, you had to jump through hoops to get Windows apps running on a foreign platform. With CrossOver for ChromeOS, you type in the Windows app's name, pick it from a list when it shows up, make sure you have the installation media, and hit install. Nothing could be easier.

CrossOver won't run all Windows programs, but it runs many of them. For example, its supported Windows applications include Microsoft Office and Quicken. CrossOver also runs games. These include such popular massively multiplayer online role-playing games (MMORPGs) games as World of Warcraft and Guild Wars.

CrossOver on Chrome OS is still a beta. While I could run some of my favorite simple programs on it, like NotePad++, a source-code editor on it, I couldn't run others. For instance, while I could install Microsoft Office 2016 on my 2015 Chromebook Pixel, Office wouldn't run on it.

Games that lock the mouse, such as first-person shooters, won't work either. That's because the required application programming interface (API) isn't in Chrome OS' current version of Android. It's expected to be added shortly. Video-heavy programs that require OpenGL also aren't supported. This is because Android only supports OpenGL ES, which is an OpenSL subset.

So, I can't recommend switching to a Chromebook to run Windows applications yet. But, the beta download is free, and it's certainly worth trying. Well, it's worth giving a shot if you have a Chromebook that supports Android. You see, CrossOver on Chrome OS is really Chromebook on Android. That means you need a newer Chromebook.

Jeremey White, CodeWeavers' founder, explained the Android connection happened because: "We've been experimenting with Android support for the past four years ... There have been a lot of challenges - and a lot of challenges remain. For example, we poured a lot of energy into making Windows applications work on a variety of Android form factors, including phones and tablets. But the brutal truth is that if I give you, say, Microsoft Word, on your phone, you'll fairly quickly figure out that you don't really want the Windows version of Word on your phone. Your fingers can't operate the menus." But, then, he said, "With the announcement of support of Android in Chrome OS, suddenly things made a lot more sense. A Chromebook has a big enough screen. And a keyboard and a mouse. And often, an Intel processor. What's more, it's really handy to have Quicken or Wizard 101 or your favorite Windows application right there."

It doesn't have to be a powerful Chromebook to run Windows apps on a Chromebook, although it must have an Intel processor. That's because CrossOver uses Wine, a lightweight program that's been used for decades now to run Windows programs on macOS, Linux, and Unix. It does this by creating a Windows API compatibility layer. This enables you to install and run 32-bit Windows software without actually running Windows.

Full Article

Friday, November 10, 2017

Putty for Mac 8.7.0 has been released with macOS High Sierra support

Wine Reviews released Putty for Mac 8.7.0 for MacOS today. Putty 8.7.0 is yet another major release,  we now have full support for macOS High Sierra. Please see the full change-log below for all the exciting changes in this release.

Putty is one of the Best Terminal Emulators available today. It Supports different types of Network Protocols such as SSH, FTP, SCP, Telnet etc. In Windows it is used as SSH Client to connect to Your Linux server or for some other purpose But what will you do if you are on Mac? You might be thinking , Is there any Software like Putty for Mac Available? The answer is Yes! With the help of some other Software’s we can Use putty on MacOS although Putty is used widely on Windows Platform. Official Versions of Putty are available on Unix like Platforms, and now it’s widely available for Mac systems running OSX 10.9.5 or higher.

SSH is available by default in Mac and Linux or Unix. Although you can use terminal for SSH connections still there are some benefits in using Putty such as Other clients don’t keep connections alive whereas Putty does. Also it is cool to use Putty as your SSH client if you are doing some Amazon AWS, VMware ESXi or CISCO Stuffs, transferring files, managing files on a server or whatever.

The cost of Putty 8.7.0 is only $15.00. Anyone who has purchased Putty in the past three months is entitled to a free upgrade. Putty comes with three months of upgrades and of course a 14-day money back guarantee.

Supported Protocols:

  • Telnet
  • FTP
  • SFTP
  • SSH
  • SCP
About Wine Reviews:

There is a multitude of software developed only for the Windows operating system and even when software vendors port their applications to another platform, generally it lacks features that the Windows version contains. The only solution these developers face is to have access to both systems for testing which leads to increased infrastructure demands, and wasted project resources. Our goal is to have native ports of essential Windows tools and applications made available for MacOS users.

Version 8.7.0 New Features:
  • Compiled PuTTY against the latest stable GTK version 3.22.20
  • Compiled PuTTY on macOS 10.13.1 High Sierra
  • Moved back to the more stable pkg installer
  • Updated the Documentation
  • Minor bug fixes
We now use FastSpring as our preferred storefront, you can pay with Credit / Debit Cards, PayPal, Amazon payments, Wire Transfer etc. etc. This store is very secure, simple and fast.

Screen Shots :


Purchase Putty 8.7.0 now and have Telnet SSH FTP SCP on your Mac made easy!

Wednesday, November 8, 2017

CodeWeavers releases a open beta of CrossOver for Chrome OS

 From Jeremy White's blog

Today is a very exciting day - we have released an open Beta of CrossOver on Chrome OS, which runs on the Android subsystem of Chrome OS and makes it possible to easily and cleanly run Windows applications on an Intel based Chromebook.

This is a particularly satisfying for me, personally.  That is, I have always loved technology best when there is are a lot of vibrant options in the market.  With the launch of CrossOver, we believe that Chrome OS becomes an even more compelling choice.

And I love this version of CrossOver; I think it's our cleanest and most elegant version yet.  It's inspired by the simplicity and elegance of Android and Chrome OS; I think it's by far the best CrossOver we've ever made.

It's been a long journey - we've been experimenting with Android support for the past four years, and it's been ten years since we added a new major operating system (we launched CrossOver Mac in January of 2007)...

https://www.codeweavers.com/store/?dealcode=unity

Full Blog post

Tuesday, October 31, 2017

The WineHQ Wine development release 2.20 is now available for Linux and Mac

The WineHQ Wine development release 2.20 is now available for Linux and Mac

What's new in this release:
  • Improved event support in MSHTML.
  • Preloader support on ARM64.
  • Interpolation modes in Direct3D.
  • Improved metafile support in GdiPlus.
  • Initial version of Kerberos5 Authentication Package.
  • OLE clipboard cache improvements.
  • Various bug fixes.
The source is available now. Binary packages are in the process of being built, and will appear soon at their respective download locations.


Bugs fixed in 2.20 (total 15):

  40873  Multiple games (Witcher 3, Firewatch, The Solus Project, Banished) require dcl_input_ps support
  41960  Totally Accurate Battle Simulator alpha crashes
  43236  F.E.A.R, Condemned: Criminal Origins have no in-game audio
  43457  The First Templar - Steam Special Edition crashes in the main menu
  43512  Hellblade: Senua's Sacrifice - the player character is severely distorted
  43572  Ham Radio Deluxe 6.4 crashes on unimplemented function ntdll.dll.RtlIpv4StringToAddressW
  43770  Fidibo installer crashes very early in win7 mode
  43810  Playkey needs api-ms-win-crt-stdio-l1-1-0.dll.__stdio_common_vsprintf_p
  43883  Endless Legend - Broken in 2.18, worked in 2.17
  43886  Xenia emulator needs api-ms-win-shcore-scaling-l1-1-1.dll
  43912  wine-2.0.3/programs/wineboot/wineboot.c:684]: (style) Suspicious condition
  43913  Process Hacker 3.x needs ntdll.dll.RtlDosPathNameToNtPathName_U_WithStatus
  43914  64-bit RPCS3 emulator doesn't start, loader reports 'Invalid address' (non-relocatable PE wants to use lowest possible image base on NT: 0x10000 / 64 KB)
  43920  Access violations during start-up of the Tina 11.0 and Circuitmaker2000 software
  43927  Wine crashes when running anything (when compiled with gcc4.2, clang works)

The newest CodeWeavers coupon promo code is ( UNITY ) save 30% off CrossOver Mac or Linux today!

Sunday, October 22, 2017

Putty for Mac 8.6.0 macOS 10.13 High Sierra preview release

PuTTY for Mac now runs on Apple's newest flagship operating system macOS 10.13 High Sierra. This new preview release also has full support for Mac OS X 10.10 Yosemite. High Sierra support continues to improve and new features are always being added to the newest releases.







Changelog :
  • Preliminary support for macOS 10.13 High Sierra
  • Full support for Mac OSX 10.10 Yosemite
  • Minor bug fixes
About PuTTY for Mac

Putty is one of the Best Terminal Emulators available today. It Supports different types of Network Protocols such as SSH, FTP, SCP, Telnet etc. In Windows it is used as SSH Client to connect to Your Linux server or for some other purpose But what will you do if you are on Mac? You might be thinking , Is there any Software like Putty for Mac Available? The answer is Yes! With the help of some other Software’s we can Use putty on MacOS although Putty is used widely on Windows Platform. Official Versions of Putty are available on Unix like Platforms, and now it’s widely available for Mac systems running OSX 10.9.5 or higher.

SSH is available by default in Mac and Linux or Unix. Although you can use terminal for SSH connections still there are some benefits in using Putty such as Other clients don’t keep connections alive whereas Putty does. Also it is cool to use Putty as your SSH client if you are doing some Amazon AWS, VMware ESXi or CISCO Stuffs, transferring files, managing files on a server or whatever.

The cost of Putty is only $15.00 for the lite version or $36.00 for the 1 year subscription option. Anyone who has purchased Putty in the past three months is entitled to a free upgrade. Putty comes with three months of upgrades for the lite version and one year of upgrades for the subscription option and of course a 14-day money back guarantee.

Supported Protocols:

  • Telnet
  • FTP
  • SSH
  • SCP
About Wine Reviews:

There is a multitude of software developed only for the Windows operating system and even when software vendors port their applications to another platform, generally it lacks features that the Windows version contains. The only solution these developers face is to have access to both systems for testing which leads to increased infrastructure demands, and wasted project resources. Our goal is to have native ports of essential Windows tools and applications made available for MacOS users.

Wednesday, October 18, 2017

Q4Wine 1.3.5 has been released for Linux and Mac OSX

Q4Wine is a Qt GUI for Wine. It will help you manage wine prefixes and installed applications. It currently supported on Linux, FreeBSD and Mac OS X platforms.

Q4Wine was initially written by Alexey S. Malakhov aka John Brezerk. General idea comes from WineTools scripts which were initially written by Frank Hendriksen.


General features are:

  • Can export Qt color theme into wine colors settings;
  • Can easy work with different wine versions at same time;
  • Easy creating, deleting and managing prefixes (WINEPREFIX);
  • Easy controlling for wine process;
  • Autostart icons support;
  • Easy cd-image use;
  • You can extract icons from PE files (.exe .dll);
  • Easy backup and restore for managed prefixes;
  • Winetriks support;
  • And more: Explore it!;
 Changelog for 1.3.5:

Updated:
  • Italian translation;
  • Ukrainian translation;
  • Russian translation;
Fixed:
  • Removed extra Doxygen files to reduce artifact size;
The newest CodeWeavers coupon promo code is ( UNITY ) save 30% off CrossOver Mac or Linux today!

The WineHQ Wine development release 2.19 is now available for Linux and Mac

The WineHQ Wine development release 2.19 is now available for Linux and Mac

What's new in this release:
  • Support for 32-bit float audio on Android.
  • Named pipes now fully handled by the Wine server.
  • Support for a new Microsoft root certificate.
  • More transform fixes in GdiPlus.
  • Some heap allocation optimizations.
  • Various bug fixes.
The source is available now. Binary packages are in the process of being built, and will appear soon at their respective download locations.


Bugs fixed in 2.19 (total 16):

   7369  eISLP -help doesn't display, 'text controller' error message
  14530  EM_PASTESPECIAL unimplemented in richedit
  33841  Paint.NET 3.5.10 fails to start
  35372  iTunes 11.1.x shows distorted UI (no text drawn, missing ui controls)
  37251  WiX Toolset v3.8 installer doesn't open with Wine-Mono (unimplemented corruntimehost_CreateDomainEx)
  37637  CreateNamedPipe,  ReadFile, PIPE_WAIT or BufferSize problem
  43044  League of Legends needs function msvcp140.dll.?__ExceptionPtrAssign@@YAXPAXPBX@Z
  43163  Mixcraft 8 crashes when adding a video track ('IAMTimelineGroup', '{9eed4f00-b8a6-11d2-8023-00c0df10d434}' not implemented, 'qedit.dll')
  43261  Error when starting the game Farming Simulator 15
  43776  .NET 4.0 installer spams with error message boxes
  43777  redefinition of typedef ‘REFERENCE_TIME’ (gcc-4.2)
  43805  Regedit.exe crashes when exporting certain registry keys e.g. "HKLM\Software\Classes\steam"
  43829  DigitalSpace Traveler: Unhandled page fault on read access
  43830  Enterprise Architect no longer loads symbols when debugging.
  43860  Microsoft DirectX 9.0c Redistributable (June 2010) installer crashes
  43877  "Cannot allocate DOS memory" error with 16-bit Windows applications

The newest CodeWeavers coupon promo code is ( UNITY ) save 30% off CrossOver Mac or Linux today!

Tuesday, October 10, 2017

The WineHQ Wine development release 2.18 is now available for Linux and Mac

The WineHQ Wine development release 2.18 is now available for Linux and Mac

What's new in this release:
  • Radial gradients in Direct2D.
  • Asynchronous message support in WebServices.
  • Virtual memory write watches improvements.
  • FreeType 2.8.1 compatibility fixes.
  • Various bug fixes.
The source is available now. Binary packages are in the process of being built, and will appear soon at their respective download locations.


 Bugs fixed in 2.18 (total 22):

  24281  Mafia 2 to slow to play
  36359  valgrind shows a couple possible leaks in dsound/tests/dsound.c
  37160  If D3D_DISABLE_9EX is defined, d3d9.h can't be compiled
  37321  foobar2000 'Scheduler' plugin crashes on unimplemented function shell32.dll.ShellExec_RunDLLW
  37418  Unable to paste images from linux clipboard to Wine apps workspace (affects Photoshop, Powerpoint etc.)
  41380  Xenia emulator don't run (needs _register_thread_local_exe_atexit_callback implementation)
  42154  Multiple games crash with built-in xinput (Deus Ex: Human Revolution, Thief (2014), Tomb Raider (2013), Bejeweled 3)
  42715  Cxbx (Xbox emulator) doesn`t start (wine: Invalid address)
  42983  Abwrite crashes with exception 0x40000015
  43324  Beamng.drive requires msvcr120.dll.vsscanf
  43326  Uplay (July 2017) needs dwmapi.DwmSetIconicLivePreviewBitmap
  43453  Magic Online  (Magic The Gathering: Online) Crashes due to race condition in secur32
  43487  Magic Online  (Magic The Gathering: Online) Crashes in dwrite
  43549  Wickr 4.0.5: Crashes upon run
  43699  Blackscreen in visual novel Hanahira
  43701  Half-Life 2 (Counter-Strike:Source, Day of Defeat:Source) crash on start
  43707  [GdiPlus] HatchStyle is incorrectly named in Wine. Should be GpHatchStyle
  43714  ImageMagick crashes with msvcr120.dll._vfprintf_l
  43715  Many applications (winecfg, ...) crash on startup with freetype 2.8.1
  43716  freetype 2.8.1 breaks Wine build during font conversion with sfnt2fon
  43774  Chromium-based browser engine (CEFv3) used by several games randomly crashes on shutdown (World of Warships 0.6.x)
  43779  In ole32/storage32.c , miss check for the result of HeapAlloc

The newest CodeWeavers coupon promo code is ( UNITY ) save 30% off CrossOver Mac or Linux today!

Thursday, October 5, 2017

Putty for Mac 8.6.0 status on macOS 10.13 High Sierra

As of today PuTTY for Mac began to run on Apple's newest flagship operating system release macOS 10.13 High Sierra. We are now in the process of updating our store with the latest and greatest release to date! If you made a purchase in the past three months we will be sending out upgrade links in the next couple of days. Customers who purchased a 1 year subscription will also get a separate upgrade notification.


About PuTTY for Mac

Putty is one of the Best Terminal Emulators available today. It Supports different types of Network Protocols such as SSH, FTP, SCP, Telnet etc. In Windows it is used as SSH Client to connect to Your Linux server or for some other purpose But what will you do if you are on Mac? You might be thinking , Is there any Software like Putty for Mac Available? The answer is Yes! With the help of some other Software’s we can Use putty on MacOS although Putty is used widely on Windows Platform. Official Versions of Putty are available on Unix like Platforms, and now it’s widely available for Mac systems running OSX 10.9.5 or higher.

SSH is available by default in Mac and Linux or Unix. Although you can use terminal for SSH connections still there are some benefits in using Putty such as Other clients don’t keep connections alive whereas Putty does. Also it is cool to use Putty as your SSH client if you are doing some Amazon AWS, VMware ESXi or CISCO Stuffs, transferring files, managing files on a server or whatever.

The cost of Putty is only $15.00 for the lite version or $36.00 for the 1 year subscription option. Anyone who has purchased Putty in the past three months is entitled to a free upgrade. Putty comes with three months of upgrades for the lite version and one year of upgrades for the subscription option and of course a 14-day money back guarantee.

Supported Protocols:

  • Telnet
  • FTP
  • SSH
  • SCP
About Wine Reviews:

There is a multitude of software developed only for the Windows operating system and even when software vendors port their applications to another platform, generally it lacks features that the Windows version contains. The only solution these developers face is to have access to both systems for testing which leads to increased infrastructure demands, and wasted project resources. Our goal is to have native ports of essential Windows tools and applications made available for MacOS users.

Putty for Mac 8.6.0 status on OS X 10.10 Yosemite

Over the past month Putty4Mac has received a higher then average number of orders and with the new influx of users we became aware of a number of outstanding bugs. Thanks in part to user feedback and testing the software in every imaginable manner or situation possible.

As of today, after a month of testing and bug fixing we believe PuTTY is now as stable and runs as well on OS X 10.10 as any other macOS operating system release.


About PuTTY for Mac

Putty is one of the Best Terminal Emulators available today. It Supports different types of Network Protocols such as SSH, FTP, SCP, Telnet etc. In Windows it is used as SSH Client to connect to Your Linux server or for some other purpose But what will you do if you are on Mac? You might be thinking , Is there any Software like Putty for Mac Available? The answer is Yes! With the help of some other Software’s we can Use putty on MacOS although Putty is used widely on Windows Platform. Official Versions of Putty are available on Unix like Platforms, and now it’s widely available for Mac systems running OSX 10.9.5 or higher.

SSH is available by default in Mac and Linux or Unix. Although you can use terminal for SSH connections still there are some benefits in using Putty such as Other clients don’t keep connections alive whereas Putty does. Also it is cool to use Putty as your SSH client if you are doing some VMware ESXi or CISCO Stuffs, transferring files, managing files on a server or whatever.

The cost of Putty is only $15.00 for the lite version or $36.00 for the 1 year subscription option. Anyone who has purchased Putty in the past three months is entitled to a free upgrade. Putty comes with three months of upgrades for the lite version and one year of upgrades for the subscription option and of course a 14-day money back guarantee.

Supported Protocols:

  • Telnet
  • FTP
  • SSH
  • SCP
About Wine Reviews:

There is a multitude of software developed only for the Windows operating system and even when software vendors port their applications to another platform, generally it lacks features that the Windows version contains. The only solution these developers face is to have access to both systems for testing which leads to increased infrastructure demands, and wasted project resources. Our goal is to have native ports of essential Windows tools and applications made available for MacOS users.

Friday, September 15, 2017

The WineHQ Wine development release 2.17 is now available for Linux and Mac

The WineHQ Wine development release 2.17 is now available for Linux and Mac

What's new in this release:
  • Better support for grayscale mode in DirectWrite.
  • Per-application StartupWMClass in desktop files.
  • Virtual memory compatibility improvements.
  • Palette handling improvements in WindowsCodecs.
  • Reply messages improvements in WebServices.
  • Various bug fixes.
The source is available now. Binary packages are in the process of being built, and will appear soon at their respective download locations.


Bugs fixed in 2.17 (total 20):

  12185  Before You Know It crashes
  19177  Gorky-17 does not start in Direct3D HAL (SW Renderer is OK)
  29958  UIRibbon Framework not implemented: 926749fa-2615-4987-8845-c33e65f2b957
  38622  gdiplus should return PixelFormat32bppARGB instead of PixelFormat8bppIndexed for a grayscale PNG file
  39885  Cannot allocate more than 32gb of memory
  41370  TTM_GETCURRENTTOOL returns always FALSE when send from TTN_NEEDTEXT handler.
  41827  Wrong specular rendering with some applications
  42427  Steam application claims no internet connection
  43046  Multiple apps need api-ms-win-crt-stdio-l1-1-0.dll.__stdio_common_vfprintf_s (Civilization VI, Mafia 3, SketchBook)
  43197  5Plus: Print dialog crashes with illegal floating point operation
  43290  MyLifeOrganized crashes when mousing over tabs
  43319  Steam Store/Uplay/Epic Games Launcher no longer display text in Windows 7 mode (libcef applications)
  43476  Skyrim hardware detection spinlocks with CSMT enabled
  43519  Path of Exile: Corrupt/flickering UI textures after ~1 minute of gameplay
  43577  unit test: DBGrid inplace editor dropdown does not work and worked on version 2.0.2
  43586  Dead Space: no shadows in game
  43649  dbgeng stub DebugCreateEx causes jadesentinel crash in JADE thin client
  43658  Text in Deletion Confirmation MsgBox has wrong background colour
  43668  Terris Universal Remote UFB 234 - update database does not work
  43685  Many games fail to start, or run without audio

The newest CodeWeavers coupon promo code is ( UNITY ) save 30% off CrossOver Mac or Linux today!

Tuesday, September 12, 2017

Connecting to Your AWS Linux Instance from MacOS Using PuTTY for Mac

Connecting to Your ( Amazon Elastic Compute Cloud ) AWS Linux Instance from MacOS Using PuTTY for Mac.

After you launch your instance, you can connect to it and use it the way that you'd use a computer sitting in front of you.

Note

After you launch an instance, it can take a few minutes for the instance to be ready so that you can connect to it. Check that your instance has passed its status checks - you can view this information in the Status Checks column on the Instances page.

The following instructions explain how to connect to your instance using PuTTY for Mac, a SSH client for Windows that has been ported to MacOS. If you receive an error while attempting to connect to your instance.

Prerequisites

Before you connect to your Linux instance using PuTTY, complete the following prerequisites:
  • Install PuTTY
    Download and install PuTTY from the PuTTY for Mac store. If you already have an older version of PuTTY for Mac installed, we recommend that you download the latest version. Be sure to install the entire suite.
  • Get the ID of the instance
    You can get the ID of your instance using the Amazon EC2 console (from the Instance ID column). If you prefer, you can use the describe-instances (AWS CLI) or Get-EC2Instance (AWS Tools for Windows PowerShell) command.
  • Get the public DNS name of the instance
    You can get the public DNS for your instance using the Amazon EC2 console (check the Public DNS (IPv4) column; if this column is hidden, choose the Show/Hide icon and select Public DNS (IPv4)). If you prefer, you can use the describe-instances (AWS CLI) or Get-EC2Instance (AWS Tools for Windows PowerShell) command.
  • (IPv6 only) Get the IPv6 address of the instance
    If you've assigned an IPv6 address to your instance, you can optionally connect to the instance using its IPv6 address instead of a public IPv4 address or public IPv4 DNS hostname. Your local computer must have an IPv6 address and must be configured to use IPv6. You can get the IPv6 address of your instance using the Amazon EC2 console (check the IPv6 IPs field). If you prefer, you can use the describe-instances (AWS CLI) or Get-EC2Instance (AWS Tools for Windows PowerShell) command. For more information about IPv6, see IPv6 Addresses.
  • Locate the private key
    Get the fully qualified path to the location on your computer of the .pem file for the key pair that you specified when you launched the instance.
  • Enable inbound SSH traffic from your IP address to your instance
    Ensure that the security group associated with your instance allows incoming SSH traffic from your IP address. The default security group does not allow incoming SSH traffic by default.

Starting a PuTTY Session

Use the following procedure to connect to your Linux instance using PuTTY. You need the .ppk file that you created for your private key. If you receive an error while attempting to connect to your instance, see Troubleshooting Connecting to Your Instance.

To start a PuTTY session
  1. (Optional) You can verify the RSA key fingerprint on your instance using the get-console-output (AWS CLI) command on your local system (not on the instance). This is useful if you've launched your instance from a public AMI from a third party. Locate the SSH HOST KEY FINGERPRINTS section, and note the RSA fingerprint (for example, 1f:51:ae:28:bf:89:e9:d8:1f:25:5d:37:2d:7d:b8:ca:9f:f5:f1:6f) and compare it to the fingerprint of the instance.
    Copy
    aws ec2 get-console-output --instance-id instance_id
    Here is an example of what you should look for:
    -----BEGIN SSH HOST KEY FINGERPRINTS-----
    ... 1f:51:ae:28:bf:89:e9:d8:1f:25:5d:37:2d:7d:b8:ca:9f:f5:f1:6f ...
    -----END SSH HOST KEY FINGERPRINTS-----
    Note that the SSH HOST KEY FINGERPRINTS section is only available after the first boot of the instance.
  2. Start PuTTY (from the Start menu, choose All Programs > PuTTY > PuTTY).
  3. In the Category pane, select Session and complete the following fields:
    1. In the Host Name box, enter user_name@public_dns_name. Be sure to specify the appropriate user name for your AMI. For example:
      • For an Amazon Linux AMI, the user name is ec2-user.
      • For a RHEL AMI, the user name is ec2-user or root.
      • For an Ubuntu AMI, the user name is ubuntu or root.
      • For a Centos AMI, the user name is centos.
      • For a Fedora AMI, the user name is ec2-user.
      • For SUSE, the user name is ec2-user or root.
      • Otherwise, if ec2-user and root don't work, check with the AMI provider.
    2. (IPv6 only) To connect using your instance's IPv6 address, enter user_name@ipv6_address. Be sure to specify the appropriate user name for your AMI. For example:
      • For an Amazon Linux AMI, the user name is ec2-user.
      • For a RHEL AMI, the user name is ec2-user or root.
      • For an Ubuntu AMI, the user name is ubuntu or root.
      • For a Centos AMI, the user name is centos.
      • For a Fedora AMI, the user name is ec2-user.
      • For SUSE, the user name is ec2-user or root.
      • Otherwise, if ec2-user and root don't work, check with the AMI provider.
    3. Under Connection type, select SSH.
    4. Ensure that Port is 22.

    
       PuTTY configuration - Session
  4. In the Category pane, expand Connection, expand SSH, and then select Auth. Complete the following:
    1. Choose Browse.
    2. Select the .ppk file that you generated for your key pair, and then choose Open.
    3. (Optional) If you plan to start this session again later, you can save the session information for future use. Select Session in the Category tree, enter a name for the session in Saved Sessions, and then choose Save.
    4. Choose Open to start the PuTTY session.

    
       PuTTY configuration - Auth
  5. If this is the first time you have connected to this instance, PuTTY displays a security alert dialog box that asks whether you trust the host you are connecting to.
  6. (Optional) Verify that the fingerprint in the security alert dialog box matches the fingerprint that you previously obtained in step 1. If these fingerprints don't match, someone might be attempting a "man-in-the-middle" attack. If they match, continue to the next step.
  7. Choose Yes. A window opens and you are connected to your instance.
    Note
    If you specified a passphrase when you converted your private key to PuTTY's format, you must provide that passphrase when you log in to the instance.

Connecting to Your Linux Instance Using SSH

After you launch your instance, you can connect to it and use it the way that you'd use a computer sitting in front of you.

Note

After you launch an instance, it can take a few minutes for the instance to be ready so that you can connect to it. Check that your instance has passed its status checks - you can view this information in the Status Checks column on the Instances page.

The following instructions explain how to connect to your instance using an SSH client. If you receive an error while attempting to connect to your instance, see Troubleshooting Connecting to Your Instance.

Prerequisites

Before you connect to your Linux instance, complete the following prerequisites:
  • Install an SSH client
    Your Linux computer most likely includes an SSH client by default. You can check for an SSH client by typing ssh at the command line. If your computer doesn't recognize the command, the OpenSSH project provides a free implementation of the full suite of SSH tools. For more information, see http://www.openssh.com.
  • Install the AWS CLI Tools
    (Optional) If you're using a public AMI from a third party, you can use the command line tools to verify the fingerprint. For more information about installing the AWS CLI, see Getting Set Up in the AWS Command Line Interface User Guide.
  • Get the ID of the instance
    You can get the ID of your instance using the Amazon EC2 console (from the Instance ID column). If you prefer, you can use the describe-instances (AWS CLI) or Get-EC2Instance (AWS Tools for Windows PowerShell) command.
  • Get the public DNS name of the instance
    You can get the public DNS for your instance using the Amazon EC2 console (check the Public DNS (IPv4) column; if this column is hidden, choose the Show/Hide icon and select Public DNS (IPv4)). If you prefer, you can use the describe-instances (AWS CLI) or Get-EC2Instance (AWS Tools for Windows PowerShell) command.
  • (IPv6 only) Get the IPv6 address of the instance
    If you've assigned an IPv6 address to your instance, you can optionally connect to the instance using its IPv6 address instead of a public IPv4 address or public IPv4 DNS hostname. Your local computer must have an IPv6 address and must be configured to use IPv6. You can get the IPv6 address of your instance using the Amazon EC2 console (check the IPv6 IPs field). If you prefer, you can use the describe-instances (AWS CLI) or Get-EC2Instance (AWS Tools for Windows PowerShell) command. For more information about IPv6, see IPv6 Addresses.
  • Locate the private key
    Get the fully qualified path to the location on your computer of the .pem file for the key pair that you specified when you launched the instance.
  • Enable inbound SSH traffic from your IP address to your instance
    Ensure that the security group associated with your instance allows incoming SSH traffic from your IP address. The default security group does not allow incoming SSH traffic by default. For more information, see Authorizing Inbound Traffic for Your Linux Instances.
Purchase Putty 8.7.0 now and have Telnet SSH FTP SCP on your Mac made easy!